sábado, 16 de febrero de 2013

Yast online update Capitulo6



Capítulo 6. YaST Online Update


openSUSE ofrece un flujo continuo de actualizaciones de software de seguridad para su producto. Por defecto, el applet de actualización se utiliza para mantener su sistema al día. Consulte la Sección 5.5, "Mantenimiento del Sistema de Up-to-date" para más información sobre el applet de actualización. Este capítulo trata de la herramienta alternativa para la actualización de paquetes de software: actualización en línea de YaST.
Los parches actuales para openSUSE ® están disponibles en un repositorio de actualizaciones de software , que se configura automáticamente durante la instalación . Como alternativa, puede agregar manualmente un repositorio de actualizaciones de una fuente de confianza. Para agregar o quitar repositorios, inicie el Administrador de repositorio con Software + repositorios de software de YaST. Más información sobre el Repository Manager en la Sección 5.4, "Gestión de repositorios de software y servicios" .
openSUSE proporciona actualizaciones con los niveles de importancia diferentes:
Actualizaciones de seguridad
Fijar los peligros graves de seguridad y siempre debe ser instalado.
Actualizaciones recomendadas
Solucionar problemas que podrían comprometer su ordenador.
Actualizaciones opcionales
Fijar no son de seguridad cuestiones pertinentes o proporcionar mejoras.

6,1. El diálogo de actualización en línea

 

El YaST Online Update diálogo está disponible en dos sabores toolkit GTK: (para GNOME) y Qt (para KDE).Ambas interfaces diferentes en apariencia pero, básicamente, proporcionan las mismas funciones. En las secciones siguientes se ofrece una breve descripción de cada uno. Para abrir el cuadro de diálogo, inicie YaST y seleccione Software + Actualización en línea . Como alternativa, se inicia desde la línea de comandos conyast2 online_update .

6.1.1. Interfaz KDE (Qt)

 

La actualización en línea de ventana consta de cuatro secciones.
Figura 6.1. YaST Online Update-Qt Interface
YaST Online Update-Qt Interface

El Resumen de la sección de la izquierda enumera los parches disponibles para openSUSE . Los parches están ordenados por relevancia seguridad: seguridad , recomendado y opcional . Puede cambiar la vista delresumen sección seleccionando una de las siguientes opciones del Show Categoría Patch :
Parches necesarios (vista predeterminada)
Non-instalados los parches que se aplican a los paquetes instalados en el sistema.
Los parches innecesarios
Los parches que se aplican a cualquiera de los dos paquetes que no están instalados en su sistema, o parches que tienen requisitos que ya se han cumplido (ya que los paquetes en cuestión ya han sido actualizadas desde otra fuente).
Todos los parches
Todos los parches disponibles para openSUSE .
Cada entrada de la lista en el Resumen sección consta de un símbolo y el nombre del parche. Para obtener una descripción de los posibles símbolos y su significado, pulse Mayús + F1 . Acciones requeridas por la Seguridad y recomendados parches son automáticamente preestablecido. Estas acciones son Autoinstall ,Autoupdate y Autodelete .
Si instala un paquete al día desde un repositorio que no sea el repositorio de actualizaciones, los requisitos de un parche para este paquete se cumpla con esta instalación. En este caso una marca de comprobación en frente de la Resumen de parche. El parche será visible en la lista hasta que se marca para su instalación. Esto no será de hecho instalar el parche (porque el paquete ya está al día), pero el parche marcar como instalado.
Seleccione una entrada en el Resumen sección para ver una breve descripción Patch en la esquina inferior izquierda del cuadro de diálogo. La sección superior derecha se muestran los paquetes incluidos en el programa elegido (un parche puede constar de varios paquetes). Haga clic en una entrada en la sección superior derecha para ver los detalles del paquete correspondiente que se incluye en el parche.

6.1.2. Interfaz de GNOME (GTK)

 

La actualización en línea de ventana consta de cuatro secciones principales.
Figura 6.2. YaST Online Update-GTK Interface
YaST Online Update-GTK Interface

La sección superior derecha muestra los disponibles (o ya instalado) parches para SUSE Linux . Para filtrar los parches en función de su importancia para la seguridad, haga clic en la correspondiente prioridad de entrada en la parte superior derecha de la ventana: Seguridad , recomendado , opcional o cualquier prioridad .
Si todos los parches disponibles ya están instalados, la lista de paquetes en la sección superior derecha mostrará ninguna entrada. La caja en la parte inferior izquierda de la sección muestra el número de parches disponibles y ya instalados y le permite cambiar la vista a cualquiera disponible o instalada parches.
Seleccione una entrada en la lista Paquetes de sección para ver una descripción del parche y más información en la esquina inferior derecha del cuadro de diálogo. Como parche puede consistir en varios paquetes, haga clic en el Se aplica a la entrada en la parte inferior derecha para ver qué paquetes se incluyen en el parche correspondiente.
Haga clic en una entrada de parche para abrir un registro con información detallada sobre el parche en la parte inferior de la ventana. Aquí se puede ver una descripción detallada parche, así como las versiones disponibles.También puede optar por instalar los parches de seguridad opcional y los parches recomendados ya están preseleccionados para su instalación.

6,2. Instalación de los parches

 

El cuadro de diálogo YaST Online Update le permite instalar todos los parches disponibles ya sea de inmediato o para seleccionar manualmente los programas que quiera aplicar a su sistema. También pueden revertir los parches que se han aplicado al sistema.
Por defecto, todos los nuevos parches (excepto opcionales unos) que están actualmente disponibles para su sistema ya están marcadas para su instalación. Ellos se aplicará automáticamente una vez que haga clic enAceptar o Aplicar .
Procedimiento 6.1. La aplicación de parches con YaST Online Update
  1. Inicie YaST y seleccione Software + Actualización en línea .
  2. Para aplicar automáticamente todos los parches nuevos (excepto opcionales unos) que están actualmente disponibles para su sistema, continúe con Aplicar o Aceptar para iniciar la instalación de los parches preseleccionados.
  3. Para modificar primero la selección de los parches que desea aplicar:
    1. Usa los filtros y puntos de vista respectivos de las interfaces GTK y Qt proporciona. Para obtener más información, consulte la Sección 6.1.1, "Interfaz KDE (Qt)" y Sección 6.1.2, "Interfaz de GNOME (GTK)" .
    2. Seleccione o anule la selección de parches de acuerdo a sus necesidades y deseos, activando o desactivando la casilla de verificación correspondiente (GNOME) o haciendo clic derecho en el parche y la elección de la acción correspondiente en el menú contextual (KDE).
      [Importante]Siempre Aplicar actualizaciones de seguridad
      No anular la selección de la seguridad relacionados con los parches sin una muy buena razón. Estos parches arreglar los graves peligros de seguridad y evitar que el sistema de la explotación.
    3. La mayoría de los parches son actualizaciones para varios paquetes. Si desea cambiar las acciones para los paquetes individuales, haga clic en un paquete en la vista de paquetes y seleccione una acción (KDE).
    4. Para confirmar su selección y aplicar los parches seleccionados, proceda con Aplicar o Aceptar .
  4. Después de que la instalación se haya completado, haga clic en Finalizar para salir del YaST Online Update . Su sistema está ahora al día.
[Tip]Desactivación deltarpms
De forma predeterminada, las actualizaciones se descargan como deltarpms. Desde la reconstrucción de paquetes rpm de deltarpms es una tarea de memoria y procesador lento, ciertas configuraciones o configuraciones de hardware posible que tenga que desactivar el uso de deltarpms por el bien de rendimiento.
Para desactivar el uso de deltarpms, edite el archivo zypp.conf / etc / ZYpp / y establecerdownload.use_deltarpm a falso .

6,3. Actualización en línea automática

 

YaST ofrece también la posibilidad de establecer una actualización automática con programación diaria, semanal o mensual. Para utilizar el módulo respectivo, es necesario instalar el yast2-online-update-configuración primer paquete.
Procedimiento 6,2. Configuración de la actualización automática en línea
  1. Después de la instalación, inicie YaST y seleccione Software + Actualización de la configuración en línea .
    También puede iniciar el módulo con yast2 online_update_configuration desde la línea de comandos.
  2. Activar actualización automática en línea .
  3. Seleccione si desea actualizar diario , semanal o mensual .
    Algunos parches, tales como actualizaciones del kernel o paquetes que requieren acuerdos de licencia, requieren la interacción del usuario, lo que haría que el procedimiento de actualización automática para detenerse.
  4. Para aceptar automáticamente cualquier contrato de licencia, active acuerdo con las licencias .
  5. Seleccione si usted también quiere Saltar parches interactivos en caso de querer el procedimiento de actualización de proceder de forma totalmente automática.


    Si opta por omitir los paquetes que requieren interacción, ejecute un manual de actualización en líneade vez en cuando con el fin de instalar los parches, también. De lo contrario, podría perder los parches importantes.
    Confirme su configuración con Aceptar .

No hay comentarios:

Publicar un comentario